Quick Links: Gideros Home | Download Gideros | Developer Guide
Export issue in Gideros Studio on Mac OS?
  • PaulH +1 -1
    Member
    This is one of those "what am I doing wrong?" moments. When working on an iOS version I've always used Gideros Studio on Windows, then exported the iOS project, moved files to a Mac, and built with X-Code. Today I tried installing Gideros on the Mac to save some file transfers when troubleshooting iOS issues. Running 2017.4.1 I found that when I exported an iOS project, whether exporting assets only or a full export, the only Lua file that got exported was main.lua. All the other assets (fonts, graphics) were exported, but the other lua files were missing from the export. I tried 2017.3.1 and had the same result. For now I'm back to doing my code editing on Windows, exporting, and transferring files to the Mac. I also tried with one of the example projects, in case my issue was specific to my project, but I got the same results. I also tried with and without encrypting code files.

    So... Am I missing something, or is there a bug in the Mac OS version of the studio that prevents the Mac OS version from exporting all the code files?

    Paul
  • Hi @Paul, I had the same problem when export my project to Android Studio from my iMac. If you are encrypting your files, you should exclude the files from execution (except init.lua and main.lua) y it works

    The only extra work I had was to make my classes local and call them with require when I really needed them something like this:
    local myClass = Core.class(Sprite)
     
    function myClass:init(conf) ... end
    function myClass:function_001()
    .
    .
    .
     
    return myClass

    so you can exclude from execution "myClass" and when you really need it in some lua file
    you only put:
    local myClass = require "myPathproject/.../myClass"
     
    local config={}
    config.x, config.y=...
    local Object = myClass(config)
    .
    .
    .


    I hope it help you
  • PaulH +1 -1
    Member
    Interesting... After making the classes local does Gideros include those lua files in the export? What I'm seeing (again, only when running Gideros Studio on a Mac) is that the lua files aren't being copied to the export folder at all, whether I select to encrypt them or not. I have several dozen lua files in a project, but the only one that shows up in the export is main.lua. I tried with the bird animation sample project, which contains main.lua and bird.lua, and when I export a project bird.lua is missing from the export.

    Paul
  • hgy29hgy29 +1 -1
    Maintainer Accepted Answer
    @PaulH, all lua files marked for execution are merged into a single main.lua file, that's why you don't see them. Main.lua in just larger;)
  • PaulH +1 -1 (+1 / -0 )
    Member
    Ah... Very interesting. Is that specific to the Mac version, or recent builds on all platforms?

    Likes: HubertRonald

  • keszegh +1 -1
    Member
    I was also wondering how come that those lua files are missing yet the project works.. now i understand.
  • keszegh said:

    I was also wondering how come that those lua files are missing yet the project works.. now i understand.


    Me too @keszegh
    http://giderosmobile.com/forum/discussion/comment/51761#Comment_51761

    Well basically I did "local" my classes because I like to know, that there is in the project that I export (Whether the project is new or an old one that isn't very large)

    I guess it should also improve the code performance somewhat since the classes are not global (correct me if I'm wrong)

    Sorry for the late reply @PaulH I should to say: "don't appear when it is build encrypt (or not)" and not only encrypt...

    PaulH said:


    I have several dozen lua files in a project



    ...If that also asked me with an application that I have (it has more than 100000 lines of code and a lot classes) I think in this case I would only exclude files for the moment without doing local classes or gradually

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with OpenID

In this Discussion

Top Posters