Quick Links: Gideros Home | Download Gideros | Developer Guide
APK export: what info is needed for Admob?
  • HolonistHolonist +1 -1
    Member
    Hi all,

    I'm still not able to receive ads from admob and applovin. I set up my ad unit over 56 hours ago, so I'm sure there must be an error on my side. I opened a new thread for this, because my issue of not being able to compile the AdsInterface plugin was solved.

    First let me list the things I think I have done right:

    Code:
    require 'ads'
    admob = Ads.new('admob')
    admob:setKey(ca-app-pub-publisherId)
    admob:showAd("auto", ca-app-pub-publisherId/adUnitId)

    Export:
    Gaming:
    - Enable Google Play Services support
    - Google Play services version: 9.2.0
    Ads:
    - Google Play services version: 9.2.0
    - Enable Admob Support

    Now the list where I'm not so sure. Do these parameters also need to be included?
    Gaming:
    - Application ID -> if this is needed, how does it look like and where to find it?
    - Api key -> if this is needed, how does it look like and where to find it? Do I need to set up someting other than just publish my App?
    Ads:
    - Application ID -> Is this the same as under Gaming? If not, where to find it?
    - Admob client key -> I'm already setting this in the code. Does it also need to be included here?
    - Admob banner key -> I'm already setting this in the code. Does it also need to be included here?


    Test ads with Admob are working. Without testing, I get HTTP error 403 in catlog on Bluestacks, and an immediate AD_DISMISSED event.

    I added two screenshots which show again which parts I do have setup and which are maybe missing.

    I know I'm going on everyone's nerves lately, but I tried everything to get this working for 5 days straight, exported my app dozens if not a hundred times with different combinations of settings, and before I finally give up, maybe someone has an idea what's wrong.
    Screenshot_20.png
    1158 x 673 - 69K
    Screenshot_21.png
    1146 x 657 - 65K
  • HolonistHolonist +1 -1
    Member
    While researching the 403 error I somewhere read there could be a problem with one's AdSense account. I also read a lot about being blocked by Admob, but that's apparently not the case with me.

    So I logged into Adsense (didn't even know I have an account), and there is some prime google bullshit going on.

    On the top of the page is a big red box saying: Currently no ads are delivered, because you didn't add payment info yet.

    And then on the page where you can add payment methods, the "add payment" button is grayed out and unclickable, with the hint "You will need to add a payment method only after your minimum payment threshold (70€) is reached."

    So how the f*** am I going to earn something to be able to add a payment method, while my ads are blocked because there is no payment method?!

    I'm not even sure if any of this is relevant for admob, I lost track of all the different portals, services and redundant settings in Google long time ago
  • totebototebo +1 -1
    Member
    If the test ads are working it seems likely that it's a config issue. Have you created the as unit you want to run in the Admob control panel, and double checked you are using those IDs in Gideros when loading/displaying the ad?
    My Gideros games: www.totebo.com
  • SinisterSoftSinisterSoft +1 -1 (+1 / -0 )
    Maintainer Accepted Answer
    Also in the latest Gideros I think you need to use above 9.2.0 for the play services. I'm using 10.0.1 for the new release candidate.

    Here is where you find the application id:
    application_id.png
    918 x 314 - 53K

    Likes: Holonist

  • SinisterSoftSinisterSoft +1 -1
    Maintainer
    The apikey is for Amazon gamecircle.

    See this screenshot
    apikey.png
    960 x 653 - 98K
  • HolonistHolonist +1 -1 (+2 / -0 )
    Member
    I works!!!

    - I had to use Google Play services 10.0.1 in both places
    - Enter App Id (com.company.app) in both places. (Thought this was already taken care of by the project settings)

    That's it.

    <3
  • HolonistHolonist +1 -1 (+1 / -0 )
    Member
    For some reason in my Bluestacks, all ads are scaled down to 50%.

    I didn't realize this and published my update without beta test.
    Ads were supposed to appear inside a very defined area of the screen, but in live they just overlap several buttons/texts.

    Nothing to fix here, just a funny story and a lesson learned: always publish beta first :D

    Likes: antix

  • totebototebo +1 -1
    Member
    Love the optional implementation of banners. Haven't seen this before. Awesome!
    My Gideros games: www.totebo.com

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with Google Sign In with OpenID

In this Discussion

Top Posters