Quick Links: Gideros Home | Download Gideros | Developer Guide
Stuck on video ads integration
  • Hi!

    A bit stuck with integration video Ads to Android project.

    Tried Chartboost, but right now there is no chartboost.jar file in libs and there is no such file in chartboost sdk. How to get it and should we still use it or smth else?

    Want to try Unity, but same problem - nothing in libs and no reference here: http://docs.giderosmobile.com/interface/ads

    If somebody has any information, please, share:)

    Thanks.
  • hgy29hgy29 +1 -1 (+1 / -0 )
    Maintainer
    Hi @unlying, if you use 2016.12 then just click 'plugins' in export window, select and tick 'Ads', then tick Chartboost in the table below and enter any additional ID required by Chartboost there too. Same for Unity!

    Likes: simwhi

  • Hi @hgy29
    No, i'm using old version.
    New version doesn't export lua files with wrong syntax. Btw these files are excluded from compiling in Gideros:
    Exporting data.lua
    D:\Gideros\Tools\luac.exe: data.lua:1: unexpected symbol near '{'
    Exporting data1.lua
    D:\Gideros\Tools\luac.exe: data1.lua:1: '=' expected near 'is'
    Exporting data10.lua
    D:\Gideros\Tools\luac.exe: data10.lua:1: '=' expected near 'n'
    Exporting data2.lua
    D:\Gideros\Tools\luac.exe: data2.lua:1: unexpected symbol near '�'
    Exporting data3.lua
    D:\Gideros\Tools\luac.exe: data3.lua:1: '=' expected near 'ist'
    Exporting data4.lua
    D:\Gideros\Tools\luac.exe: data4.lua:1: '=' expected near 'no'
    Exporting data5.lua
    D:\Gideros\Tools\luac.exe: data5.lua:1: '=' expected near 'non'
    Exporting data6.lua
    D:\Gideros\Tools\luac.exe: data6.lua:1: '=' expected near 'est'
    Exporting data7.lua
    D:\Gideros\Tools\luac.exe: data7.lua:1: '=' expected near '�'
    Exporting data8.lua
    D:\Gideros\Tools\luac.exe: data8.lua:1: '=' expected near 'tidak'
    Exporting data9.lua
    D:\Gideros\Tools\luac.exe: data9.lua:1: '=' expected near 'bir'
    Exporting dataa.lua
    D:\Gideros\Tools\luac.exe: dataa.lua:1: unexpected symbol near '4'
  • hgy29hgy29 +1 -1
    Maintainer
    Yes, you're right, gideros export shouldn't try to compile files excluded from execution. It never occured to me that lua files could not be compilable until now :P If thats the only issue with newest version you could consider changing the extension of those lua files, I don't know if this is a huge effort in your case or not.

    Problem with older versions is that libs may be out of date, anyway chartboost.jar used to be shipped with gideros somewhere in All Plugins/ads folder. On the other hand, Unity requires UnityAds.aar to be downloaded from UnityAds repo, and as far as I know it requires Android Studio.
  • Tried without them.
    Frameworks folder is empty. Libs too. There is nothing about integration these systems to project.

    *Eclipse.
    Copying C:/export/removeapic/src/com/giderosmobile/android/plugins/ads/Ads.java
    Copying C:/export/removeapic/src/com/giderosmobile/android/plugins/ads/AdsInterface.java
    Copying C:/export/removeapic/src/com/giderosmobile/android/plugins/ads/AdsManager.java
    Copying C:/export/removeapic/src/com/giderosmobile/android/plugins/ads/AdsState.java
    Copying C:/export/removeapic/src/com/giderosmobile/android/plugins/ads/AdsStateChangeListener.java
    Replaced project.namews by removeapic @0
    Template: Activity from [] to []
    Processing template
    Updating C:/export/removeapic/src/com/giderosmobile/android/removeapicActivity.java
    Updated:4 replacements
    Set: local.adsfwd -> src/main/java/com/giderosmobile/android/plugins/ads/frameworks
    Replaced sys.pluginDir by D:/Gideros/All Plugins/ads @0
    Set: local.adsfws -> D:/Gideros/All Plugins/ads/bin/Android/src/com/giderosmobile/android/plugins/ads/frameworks
    Replaced local.adsfwd by src/main/java/com/giderosmobile/android/plugins/ads/frameworks @0
    MkDir: src/main/java/com/giderosmobile/android/plugins/ads/frameworks
    Replaced plugin.adsFwUnity by 1 @0
    If: 1
    Replaced local.adsfwd by src/main/java/com/giderosmobile/android/plugins/ads/frameworks @0
    Replaced local.adsfws by D:/Gideros/All Plugins/ads/bin/Android/src/com/giderosmobile/android/plugins/ads/frameworks @0
    Template: Unity Ads from [D:/Gideros/All Plugins/ads/bin/Android/src/com/giderosmobile/android/plugins/ads/frameworks] to [src/main/java/com/giderosmobile/android/plugins/ads/frameworks]
  • hgy29hgy29 +1 -1 (+1 / -0 )
    Maintainer
    @unlying, it seems your are using Eclipse, can you try with Android Studio ? As said a few weeks ago we are moving away from Eclipse so we don't usually bother maintaining plugins for Eclipse...

    Likes: antix

  • So hard for me to move on Android Studio :(


    1) Admob was checked, but file AdsAdmob.java wasn't added during export.
    2) Added src file manually, but has an error "Multiple dex files define Lcom/google/android/gms/internal/zzau"
    3) Changed gradle to
    	           	         //  compile 'com.google.android.gms:play-services:9.2.0'
     
     
    compile files('libs/chartboost-sdk-6.6.1.jar')
    compile 'com.google.android.gms:play-services-ads:9.2.0'


    Finally it works for unity. Have no success with chartboost still(Network error).

    Thanks.
  • hgy29hgy29 +1 -1
    Maintainer Accepted Answer
    Thanks for reporting :) I didn't have a chance to test AdMob, obviously the integration script needs a few changes. A few ad providers needs googleplay services, like chartboost or applovin. Did you enter your GMS ID in the 'Application Id' field of ads property table ?

    I agree that Android Studio is far from being perfect (seems less efficient than eclipse to me), but once you set it up correctly, gideros can generate APK for you.
  • A few ad providers needs googleplay services, like chartboost or applovin
    No, I haven't knowledge about that. Chartboost works for me without them before(years ago). I'll try, thanks.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Login with Facebook Sign In with OpenID

In this Discussion

Top Posters