Quick Links: Download Gideros Studio | Gideros Documentation | Gideros Development Center | Gideros community chat
Beginner - apk - Gideros Forum

Beginner - apk

adityaaditya Member
edited January 2013 in Step by step tutorials
Just started with gideros studio. I have installed the giderosandroidplayer.apk on my device and it remote executes just fine.

How do I deploy a standalone apk? (Have downloaded eclipse and the jdk). A step by step would really help.
Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"

Comments

  • Are you familiar with Eclipse?

    From Gideros Export the project
    In Eclipse import the project
    Then it is as simple as simply Running the project to the emulator or the connected device.
    twitter: @ozapps | http://www.oz-apps.com | http://howto.oz-apps.com | http://reviewme.oz-apps.com
    Author of Learn Lua for iOS Game Development from Apress ( http://www.apress.com/9781430246626 )
    Cool Vizify Profile at https://www.vizify.com/oz-apps
  • to create an .apk for the store you will have to export the project and select the signatures to sign the apk, etc.

    Dislikes: MomPemsPads

    twitter: @ozapps | http://www.oz-apps.com | http://howto.oz-apps.com | http://reviewme.oz-apps.com
    Author of Learn Lua for iOS Game Development from Apress ( http://www.apress.com/9781430246626 )
    Cool Vizify Profile at https://www.vizify.com/oz-apps
    +1 -1 (+0 / -1 ) Share on Facebook
  • Don't use the normal eclipse export - use Android>export>signed ....

  • Thanks guys for the quick answers.

    Actually, i have never worked on java. I love this engine because it uses lua.

    Got 6 errors, 3 warnings in eclipse all related to Security.java. Some thread suggested downloading all the sdk versions so doing that right now.
    Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"
  • hgvyas123hgvyas123 Guru
    edited January 2013
    as far as i know using latest version of android sdk will not cause any problem and there is no need to download any extra files so what version are u using i think 4.1 or 4.2 is the latest as well as do you have latest version of Gideros?

    :)
  • On a post whoring mission - nothing to see here (It's not my fault! )
    WhiteTree Games - Home, home on the web, where the bits and bytes they do play!
    #MakeABetterGame! "Never give up, Never NEVER give up!" - Winston Churchill
  • adityaaditya Member
    edited February 2013
    I have 4.2 installed currently. Downloading everything upto 1.5.
    [Edit]: Gideros v2012.09.6

    @techdojo: o_O
    Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"
  • did you mean downloading android sdk 1.5 ? if yes no need of that which error you are getting currently
  • Errors:
    1) Base64DecoderException cannot be resolved to a type Security.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    2) The import com.giderosmobile.android.plugins.googlebilling.util cannot be resolved Security.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    3) Base64 cannot be resolved Security.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    4) The method asBinder() of type IMarketBillingService.Stub must override a superclass method IMarketBillingService.java /HelloBall/gen/com/android/vending/billing

    5) The method asBinder() of type IMarketBillingService.Stub.Proxy must override a superclass method IMarketBillingService.java /HelloBall/gen/com/android/vending/billing

    6) The method onServiceConnected(ComponentName, IBinder) of type BillingService must override a superclass method BillingService.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    7) The method onServiceDisconnected(ComponentName) of type BillingService must override a superclass method BillingService.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    8) The method sendBillingRequest(Bundle) of type IMarketBillingService.Stub.Proxy must override a superclass method IMarketBillingService.java /HelloBall/gen/com/android/vending/billing


    Warnings:
    1) Class is a raw type. References to generic type Class should be parameterized PurchaseObserver.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    2) The import android.os.Handler is never used PurchaseObserver.java /HelloBall/src/com/giderosmobile/android/plugins/googlebilling

    3) The method getInterfaceDescriptor() from the type IMarketBillingService.Stub.Proxy is never used locally IMarketBillingService.java /HelloBall/gen/com/android/vending/billing
    Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"
  • atilimatilim Maintainer
    @aditya - Also can you right click your project name, select "Properties...", select "Java Compiler", select "Enable project specific settings", select "1.6" as "Compiler compliance level"?

    Also right click project name > Android Tools > Fix Project Properties should do the work.
    scr.png
    706 x 696 - 76K
    scr.png 76.2K
  • adityaaditya Member
    edited February 2013
    1.5 throws 11 errors...1.6 brings it down to 6... :)

    Screenshots attached.
    eclipse_1.5.jpg
    1365 x 728 - 326K
    eclipse_1.6.jpg
    1365 x 726 - 264K
    Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"
  • atilimatilim Maintainer
    edited February 2013 Accepted Answer
    @aditya we're so close. don't give up :)

    Can you check if these files exist:
    {your export directory}/src/com/giderosmobile/android/plugins/googlebilling/util/Base64.java
    {your export directory}/src/com/giderosmobile/android/plugins/googlebilling/util/Base64DecoderException.java
    - If they exist, refresh/clean your project and restart Eclipse.
    - If they don't exist, download the latest version of Gideros, install and reexport your project.
  • Ok...v2012.09.6 was not creating the util folder and the 2 files in it.

    Downloaded the latest version. Works.

    Thanks @atilim, solution and the encouragement...:)
    Loon Games LinkedIn Facebook Twitter - "Something bit me, gaah!"
  • atilimatilim Maintainer
    Accepted Answer
    :) I'm glad. Also I'll download and test 2012.09.6 to understand what's wrong with it.
  • atilimatilim Maintainer
    I've tested 2012.09.6 on Windows and Mac and it also exports these 2 files correctly. I cannot guess what was wrong on your side. But anyway, now it's working :)

    Likes: aditya

    +1 -1 (+1 / -0 ) Share on Facebook
  • BJGBJG Member
    edited February 2013
    I find Eclipse very confusing at the moment, and have also seen errors connected with this "Google Billing" thing.

    I just installed the latest Gideros release (2012.09.9) and loaded the bird animation demo, exported for Android, then pointed Eclipse at the exported folder with File...Import...General...Existing Projects into Workspace. (Compiler compliance level is 1.6.) It then shows the warnings in the screenshot below. It seems to run OK on the Kindle Fire emulator I installed though, so I guess maybe they don't matter.

    (I keep getting the error "Application package 'AndroidManifest.xml' must have a minimum of 2 segments" with my own experimental program and have no idea what it means, but I haven't Googled that thoroughly yet so I guess I'm just being lazy posting it...)
    error1.jpg
    1366 x 768 - 285K
  • BJGBJG Member
    edited February 2013
    OK, I give up. Here's the error on the program called "Campanology". (It's a simple thing with some ringing bells that works fine on the player. The problem seems to be connected to Google Billing again.)

    *edit* I think maybe the problem is the package name when I export it...haven't figured out what I'm supposed to be doing here yet...
    camperror.jpg
    1366 x 768 - 765K
  • BJGBJG Member
    edited February 2013
    Here's the latest...now calling the package "com.android.Campanology" but Eclipse still doesn't seem to like the Billing folder...? (This app doesn't do anything remotely as complicated as trying to bill anyone.)

    Actually I think it is running now though, despite the warnings...
    error3.jpg
    1224 x 768 - 331K
Sign In or Register to comment.